[ Регистрация · Вход · Новые сообщения · Участники · Правила форума · Поиск · RSS ]
  • Страница 1 из 1
  • 1
Модератор форума: irakitin2014  
Форум » Excel » Формулы » Динамический список заполнение (Заполнение номенклатуры одного листа данными другого листа.)
Динамический список заполнение
OZZДата: Вторник, 04.06.2019, 18:33 | Сообщение # 1
Рядовой
Группа: Проверенные
Сообщений: 7
Репутация: 0
Статус: Offline
Добрый день! Есть проблема и не знаю как реально ее можно решить.. Есть список выгруженный с номенклатурой на одном листе с данными выгрузки из базы, и есть лист на котором нужно заполнить этот же перечень из листа 1, но так чтобы уникальное значение которого нет на листе 2 туда автоматически добавилось, а повторяющиеся названия не добавлялись. Вообще так можно?
Прикрепления: 9289295.xlsx(13.8 Kb)
 
irakitin2014Дата: Среда, 05.06.2019, 13:00 | Сообщение # 2
Генерал-майор
Группа: Модераторы
Сообщений: 284
Репутация: 6
Статус: Offline
Доброго и вам!!! Вы знаете я что то не нашел на листе "Выгрузка данные " никаких повторов. 
Цитата OZZ ()
Вообще так можно?

можно скорее всего. Вы только на листе "Материалы списание" ручками нарисуйте что и как надо



для спасибов ЯД 41001877306852
 
OZZДата: Среда, 05.06.2019, 15:17 | Сообщение # 3
Рядовой
Группа: Проверенные
Сообщений: 7
Репутация: 0
Статус: Offline
Добрый ) Я уже подумала после, что надо было добавить повторяющиеся данные. Сейчас добавила. Приблизительно так.
Прикрепления: 0285097.xlsx(14.2 Kb)
 
irakitin2014Дата: Среда, 05.06.2019, 15:45 | Сообщение # 4
Генерал-майор
Группа: Модераторы
Сообщений: 284
Репутация: 6
Статус: Offline
ну если только вытащить уникальные материалы то ловите
Код
=ЕСЛИОШИБКА(ИНДЕКС('Выгрузка данные   '!$E$2:$E$8;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ('Выгрузка данные   '!$E$2:$E$8;'Выгрузка данные   '!$E$2:$E$8;0)=СТРОКА('Выгрузка данные   '!$E$2:$E$8)-1;СТРОКА('Выгрузка данные   '!E2:E8)-1);СТРОКА(A1)));"")

формула массива. вводится одновременным нажатием трех клавиш Ctrl+Shift+Enter
Прикрепления: OZZ.xlsx(14.8 Kb)



для спасибов ЯД 41001877306852
 
irakitin2014Дата: Среда, 05.06.2019, 15:54 | Сообщение # 5
Генерал-майор
Группа: Модераторы
Сообщений: 284
Репутация: 6
Статус: Offline
и таки да, кстати: а повторяющийся материал всегда будет с одним и тем же документом проходить?


для спасибов ЯД 41001877306852
 
OZZДата: Среда, 05.06.2019, 17:28 | Сообщение # 6
Рядовой
Группа: Проверенные
Сообщений: 7
Репутация: 0
Статус: Offline
Нет. Повторяющиеся наименования могут как одним так и другим документом проходить. Но важно именно само наименование.

Добавлено (05.06.2019, 17:38)
---------------------------------------------
Спасибо большое!!! попробую ввести формулу, посмотрю что получается) Если сработает, то спасет от жути жуткой постоянных ручных поисков..

 
irakitin2014Дата: Четверг, 06.06.2019, 07:13 | Сообщение # 7
Генерал-майор
Группа: Модераторы
Сообщений: 284
Репутация: 6
Статус: Offline
Цитата OZZ ()
Повторяющиеся наименования могут как одним так и другим документом проходить

Ха. тогда это уже не уникальные, раз доки разные. там уже надо немного другой подход. или вам номер документа по барабану?



для спасибов ЯД 41001877306852
 
OZZДата: Четверг, 06.06.2019, 08:59 | Сообщение # 8
Рядовой
Группа: Проверенные
Сообщений: 7
Репутация: 0
Статус: Offline
Да попробовала, пока не очень... Новые значения не добавляются. Да сам документ прихода по барабану. Смысл, найти одинаковое наименование материала, чтобы по нему потом фиксировать его количество и списание. Если наименования материала в таблице списание нет, то добавить новое название в список. Как материал пришел, каким документом не важно.
 
irakitin2014Дата: Четверг, 06.06.2019, 09:03 | Сообщение # 9
Генерал-майор
Группа: Модераторы
Сообщений: 284
Репутация: 6
Статус: Offline
Цитата OZZ ()
пока не очень...

а что не получается?



для спасибов ЯД 41001877306852
 
OZZДата: Четверг, 06.06.2019, 10:33 | Сообщение # 10
Рядовой
Группа: Проверенные
Сообщений: 7
Репутация: 0
Статус: Offline
Если наименование одно из поменять на новое, оно не появляется в листе списания, т.е. он не понимает, что наименование стало новым и такого нет, соответственно не добавляет его туда. И почему-то расширить диапазон проверяемых при расширении выгрузки не выходит. Скорее всего тут я что то не то делаю, пока вожусь...
 
irakitin2014Дата: Четверг, 06.06.2019, 10:47 | Сообщение # 11
Генерал-майор
Группа: Модераторы
Сообщений: 284
Репутация: 6
Статус: Offline
покажите в файле что не так. и не забывайте про
Цитата irakitin2014 ()
формула массива. вводится одновременным нажатием трех клавиш Ctrl+Shift+Enter



для спасибов ЯД 41001877306852
 
OZZДата: Четверг, 06.06.2019, 12:05 | Сообщение # 12
Рядовой
Группа: Проверенные
Сообщений: 7
Репутация: 0
Статус: Offline
Вот добавила несколько пунктов, и попыталась расширить диапазон. В итоге вообще ничего не получается. Явно что то не верно делаю...
Прикрепления: OZZ_2.xlsx(15.2 Kb)
 
irakitin2014Дата: Четверг, 06.06.2019, 12:25 | Сообщение # 13
Генерал-майор
Группа: Модераторы
Сообщений: 284
Репутация: 6
Статус: Offline
расширил вам диапазон до 1000 строк. 
Код
=ЕСЛИОШИБКА(ИНДЕКС('Выгрузка данные   '!$E$2:$E$1000;НАИМЕНЬШИЙ(ЕСЛИ(ЕСЛИОШИБКА(ПОИСКПОЗ('Выгрузка данные   '!$E$2:$E$1000;'Выгрузка данные   '!$E$2:$E$1000;0);ЛОЖЬ)=СТРОКА('Выгрузка данные   '!$E$2:$E$1000)-1;СТРОКА('Выгрузка данные   '!$E$2:$E$1000)-1);СТРОКА(A1)));"")

если надо больше вот эту часть $1000 в формуле замените на $тут нужное вам число
и ведь писал же вам 
Цитата irakitin2014 ()
формула массива. вводится одновременным нажатием трех клавиш Ctrl+Shift+Enter
Прикрепления: OZZ_2222.xlsx(15.3 Kb)



для спасибов ЯД 41001877306852
 
OZZДата: Четверг, 06.06.2019, 12:52 | Сообщение # 14
Рядовой
Группа: Проверенные
Сообщений: 7
Репутация: 0
Статус: Offline
Ураа!! Вроде получилось. Все видит, попробую прогрузить теперь базу). Оказывается из формулы пропала  важная часть))) Думаю поэтому и с расширением диапазона не должно быть проблем. Спасибо!!!!
 
irakitin2014Дата: Четверг, 06.06.2019, 13:19 | Сообщение # 15
Генерал-майор
Группа: Модераторы
Сообщений: 284
Репутация: 6
Статус: Offline
пишите если что


для спасибов ЯД 41001877306852
 
Форум » Excel » Формулы » Динамический список заполнение (Заполнение номенклатуры одного листа данными другого листа.)
  • Страница 1 из 1
  • 1
Поиск: