[ Регистрация · Вход · Новые сообщения · Участники · Правила форума · Поиск · RSS ]
  • Страница 1 из 1
  • 1
Модератор форума: irakitin2014  
Форум » Excel » Вопросы по Excel » Как удалить строки с одинаковыми числами в них?
Как удалить строки с одинаковыми числами в них?
ATGДата: Воскресенье, 29.04.2018, 12:11 | Сообщение # 1
Рядовой
Группа: Пользователи
Сообщений: 1
Репутация: 0
Статус: Offline
Как удалить строки с одинаковыми числами в них?
1 2 3 4 4 5
1 2 3 4 5 6
2 2 4 6 6 7
После удаления должна остаться только первая строка

Добавлено (29.04.2018, 12:11)
---------------------------------------------
Должна остаться 2 строка т.к.она не имеет одинаковых значений

 
irakitin2014Дата: Понедельник, 30.04.2018, 08:26 | Сообщение # 2
Генерал-майор
Группа: Модераторы
Сообщений: 208
Репутация: 5
Статус: Offline
И вам здравствуйте. tongue 
Здесь только макросом.формулы не умеют удалять строки. но без вашего файла написать макрос довольно проблематично



для спасибов ЯД 41001877306852
 
PelenaДата: Пятница, 04.05.2018, 11:07 | Сообщение # 3
Рядовой
Группа: Проверенные
Сообщений: 10
Репутация: 3
Статус: Offline
Если числа в разных ячейках, то можно в доп. столбец формулу 
Код
=СУММПРОИЗВ(1/СЧЁТЕСЛИ(A1:F1;A1:F1))=СЧЁТ(A1:F1)
или формулу массива 
Код
=И(СЧЁТЕСЛИ(A1:F1;A1:F1)=1)
потом отфильтровать по критерию ЛОЖЬ и удалить отфильтрованные строки
 
olgaplohova72Дата: Пятница, 18.05.2018, 14:04 | Сообщение # 4
Рядовой
Группа: Проверенные
Сообщений: 6
Репутация: 0
Статус: Offline
Круто tongue
 
Форум » Excel » Вопросы по Excel » Как удалить строки с одинаковыми числами в них?
  • Страница 1 из 1
  • 1
Поиск: