[ Регистрация · Вход · Новые сообщения · Участники · Правила форума · Поиск · RSS ]
Страница 1 из 11
Модератор форума: irakitin2014 
Форум » Excel » Вопросы по Excel » Как в формулу расчета комиссии добавить функцию Если?
Как в формулу расчета комиссии добавить функцию Если?
05ramriz24Дата: Суббота, 16.12.2017, 20:25 | Сообщение # 1
Рядовой
Группа: Проверенные
Сообщений: 4
Репутация: 0
Статус: Offline
Добрый день. 
В прикрепленном файле находится шаблон задачи. Уже почти готовый. Осталось только исправить последнюю формулу, которая не достаточна универсальна. 
В ячейке I25 есть формула, которая делится на 2 части, исходя из диапазонов, которые учитываются: 
СУММ(ЕСЛИ(И(I2<=B4;B4<K2);C4*B8/ЕСЛИ(ГОД(B1)=2016;366;365)*27,9%;0);ЕСЛИ(И(I2<=B3;B3<K2);C3*B7/ЕСЛИ(ГОД(B1)=2016;366;365)*27,9%;0); 
ЕСЛИ(И(E2<=B4;B4<I2);C4*J2/ЕСЛИ(ГОД(B1)=2016;366;365)*27,9%;0);ЕСЛИ(И(E2<=B3;B3<I2);C3*J2/ЕСЛИ(ГОД(B1)=2016;366;365)*27,9%;0)) 

Вместо выделенной ячейки С4, нужно вставить условие "Если 1 операция - снятие, то I12" и "Если 1 операция - покупка, то C4".
а вместо ячейки С3 - "Если 1 операция - снятие, то I12" и "Если 1 операция - покупка, то C3"

Добавлено (16.12.2017, 20:25)
---------------------------------------------
Надо как то вместе соединить функции ДАТА, ВПР, МИН. Но пока я не могу понять как. 

Если кто-нибудь знает как упростить формулу расчета комиссии за снятие средств, скажите пожалуйста. А то получилась очень длинной.

Прикрепления: 6783050.xlsx(13Kb)
 
PelenaДата: Воскресенье, 14.01.2018, 10:16 | Сообщение # 2
Рядовой
Группа: Проверенные
Сообщений: 8
Репутация: 2
Статус: Offline
Здравствуйте.
Вашу формулу уже можно немного сократить
Код
=СУММ(ЕСЛИ(И(I2<=B4;B4<K2);C4*B8;0);ЕСЛИ(И(I2<=B3;B3<K2);C3*B7;0);ЕСЛИ(И(E2<=B4;B4<I2);C4*J2;ЕСЛИ(И(E2<=B3;B3<I2);C3*J2;0)))/ЕСЛИ(ГОД(B1)=2016;366;365)*27,9%

Про остальное не совсем понятно, что значит
Цитата 05ramriz24 ()
Если 1 операция - покупка
 
Форум » Excel » Вопросы по Excel » Как в формулу расчета комиссии добавить функцию Если?
Страница 1 из 11
Поиск: